MT Pro Throttle Servo Braking Problem??

pfrederi

Well-Known Member
Messages
91
Hello All
This may have been brought up before but i couldnt find the exact same issue Im having. What is up with the braking ?? Just when everythings working fine all of a sudden I have no braskes. Whats weird is the servo is moving (or appears to be moving) like it should but theres no braking power like before. I checked all my settings on my radio transmitter to make sure something wasnt changed. Does anyone have any ideas of what issue might be?? Iv e had a similar issue before and wasnt sure what it might be but i replaced the brake discs AND the servo. It started working fine but i still didnt isolate the problem and now it appears to be back. The servo I have installed is the Savox 0230MG (Digital). Can anyone recommend a better\stramnger servo ?? I cant keep ordersing new servos and brake discs and it hasnt even been a couple months since i installed them. This Rampage MT Pro seems to have a weird braking problem. Is there a way to isolate if its the servo or something else?? I put my finger against the servo horn and apllied braking and it seems strong enough but when i hook it back up to the linkage and apply the brake the discs still turn with the brake fully applied.

BTW the Brake discs, Brake pads and Servo are all new. Replace couple months ago.

Thanks for input
 

pfrederi

Well-Known Member
Messages
91
Is there another servo anyone can recommend since ive replaced with the same exact one in both instances?? It looks like Maybe pointing more to the servo being a problem. I dnt mind switching brands bcuz something funky is going on. Something thats comparable and has power and torque as the SAVOX 0230MG that will fit the MT. A good brand that has good rep of not having servos go bad or semi-bad in short time lol.

Thanks
 

pfrederi

Well-Known Member
Messages
91
Just FYI.

I figured out the problem for anyone else that may have this issue again. There are 2 set screws that go into the piece that holds the brake plates. One of those screws fell out. These crews can be adjusted to make the brake tighter or looser. I replacd the set screw and adjusted both screws and stops like champ again. Pnly downside I had take a whole lotta crap apart to do it and put back togerther just to do that.
 

Phill2

LSF Plus Member
PLUS member
Messages
1,366
Location
The Rock QLD Aus
Yep that's the adjusters.
I adjusted mine in place.
You can just get a 2.5 mm hex in from behind but it's a tight squeeze.
Didn't make any difference to mine though.
 

pfrederi

Well-Known Member
Messages
91
You might wanna try replacing the the brake pads AND discs. At first time i had this issue thats what i did and it worked until now. For some reason either the discs get scorched and become smooth along with the pads. I tried cleaning them with alcohol before replacng them but that did not work either until i put in new brake pads and discs. I do agree its a weird issue though.

"Didn't make any difference to mine though."
So Phill2 how are you stopping the truck now?? LOL
 

Phill2

LSF Plus Member
PLUS member
Messages
1,366
Location
The Rock QLD Aus
Thanks for the tip.
I haven't run it since I hit a guy in the ankle.
Luckily it was just rolling at the time.
I've got to find time to pull it down.
I'm running my other one in the meantime.
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock    No Thanks