Premium members don't see ads. Click here to upgrade.

My HPI 26 Baja 5b SS

evssv

Well-Known Member
Messages
2,817
Location
Bristol uk
had this at christams as a pretty much stock ss....but not no more....lots of tr bits..phatdad...vertigo..uber/predator pipe....irc full chassis/brace kit....team chase...dark soul....hitec/savox servos...irp.....killer rc....ddm...gtb....hemistorm.....threshold....swingy p....area rc....rpm...snappy rc.....madmax....
.20160325_132445_zpsnkjfgesu.jpg
20160323_225925_zpsj7lphvmv.jpg
normally travel like this.....20160306_125555_zpspiivnexl.jpg...or20160320_135713_zpsplrqt96l.jpg
hopefully I can strap the mcd on ...lol!!also started racing at mmr racway ..did a sticker bombed race body...
20160310_215319_zpsttp4gvl1.jpg
20160310_212416_zpsdfkcrbzm.jpg
20160310_212323_zpspqvztwyg.jpg
20160310_212058_zpsc4qzy3wf.jpg
my baj on the most expensive rc pile ever..lol!!20160312_223823_zpsyqiq5osh.jpg
 
Last edited:

evssv

Well-Known Member
Messages
2,817
Location
Bristol uk
the black plastic bit??the previous owner musta chopped it....to aid cooling I guess....
 

madmanandrewk

Well-Known Member
Messages
50
That only hinders cooling. Your flywheel is a fan that forces air up through that shroud and across the head; without the shroud you have no cooling. You haven't had any overheating/tuning issues?
 

evssv

Well-Known Member
Messages
2,817
Location
Bristol uk
That only hinders cooling. Your flywheel is a fan that forces air up through that shroud and across the head; without the shroud you have no cooling. You haven't had any overheating/tuning issues?
not really..its ran sweet for the last 15ltrs of fuel since xmas...so u thk I should replace it then???chk the vids I jus uploaded....
 

evssv

Well-Known Member
Messages
2,817
Location
Bristol uk
wow....looooonnnnng time since I last updated this....:ROFLMAO:......seiing as my stock nimh is officially dead..(n)..time for a upgrade I thk....:cool:
https://www.amazon.co.uk/Gens-ace-4000-mAh-Receiver-Helicopter/dp/B01EIN4LXG/ref=sr_1_1?ie=UTF8&qid=1541546826&sr=8-1&keywords=Gens+ace+4000mAh+7.4V+2S1P
25 quid delivered.....:p...took it out last wk end...20181028_123025 by evssv, on Flickr
...first time since aug bashfest....and it ran sweet .:cool:...until the rx battery died.20181028_140658 by evssv, on Flickr
and then my life one was dead.....:rolleyes:
20181028_140802 by evssv, on Flickr
.....:(
20181028_132109 by evssv, on Flickr
 

Seandonato73

Well-Known Member
Messages
1,217
Hmm guess it's time to fix my savage. Last outing I blew the rear diff...... your vid makes me miss having it going
 

Z.hb71

Well-Known Member
Messages
3,780
Location
Manvel, Texas
had this at christams as a pretty much stock ss....but not no more....lots of tr bits..phatdad...vertigo..uber/predator pipe....irc full chassis/brace kit....team chase...dark soul....hitec/savox servos...irp.....killer rc....ddm...gtb....hemistorm.....threshold....swingy p....area rc....rpm...snappy rc.....madmax....
.View attachment 43759
View attachment 43760
normally travel like this.....View attachment 43761...orView attachment 43762
hopefully I can strap the mcd on ...lol!!also started racing at mmr racway ..did a sticker bombed race body...
View attachment 43763
View attachment 43764
View attachment 43765
View attachment 43766
my baj on the most expensive rc pile ever..lol!!View attachment 43767
Good job, all your trucks are awsome 👍
 

evssv

Well-Known Member
Messages
2,817
Location
Bristol uk
Got me servo now(y)
https://flic.kr/p/2aYzuA9 Guess i need to try it now not 3 months time :rolleyes:...:LOL:
so.....tested servo....its seems sweet......(y)......unplugged the 6.6v savox 1231......and plugged in new hv one.....still doing the same thing.:unsure:..shutting down....:rolleyes:........tried the new hv and a hitec d845.....still shutting down..:unsure:...so tried a 6.6v life battery...all good with all servos..:unsure:..so only 1 conclusion....this particular fs rx aint liking the 7.4v lipo......(n).......which is strange as 3x of my others....the mcd....mtxl...and 5ive all have the same fs tx/rx`s and all run 7.4v lipo with no probs wot so ever....:unsure:...so I now have the 6.6v in there along with the savox sa1231 as I cant b assed to swap out the rx..:rolleyes:.plus I not I even sure I gota spare one here anyways........:unsure:
 

evssv

Well-Known Member
Messages
2,817
Location
Bristol uk
Your most likely over amp the RX.try with just your new servo and see what it does
I tried all combinations of servos...both 6.6v and hv ones..and ,mixed.(y)..still cut out..(n). but I did read that if u plug the lipo directly into the fs rx....it should work..:unsure:..I have it in to a Y lead on here.......soooo...may jus b that ....but I didn't try....as read this afterwards..:rolleyes:...but then I`m sure on my others there not directly into the rx power channel....:unsure:....
......
 
Premium members don't see ads. Click here to upgrade.
Top