Problems with my range/servo glitching

-Dusty-

Well-Known Member
Messages
75
Location
Alberta Canada
So I got everything ready to go finally and I started my break in. Huge problems though.

First problem is that 9 times out of 10 times I turn my 5t on, the throttle servo is glitching like crazy. Unable to drive since it will go full throttle or break back and forth. The one time out of ten it doesn't glitch out and I can drive fine. But there is still tons of servo noise (chatter) Now comes the second problem

I have the Flysky noble and binding and setup was easy and had no issues with the killswitch and such. Huge problem is when I go about 30 ft it goes out of range. On my transmitter it shows a strong signal then bam signal loss.

So I don't know if these two things are related

I read another thread about someone having trouble with range and he moved the ferrite bead close to the rx, thought I would try that but no difference. Hoping I didn't damage the antenna or anything like that.
 

Basher5iveT420

LSF Plus Member
PLUS member
Messages
209
Location
Florida
Hey man, something is off with either the servo or receiver. I would try switch the channels around and see if that does anything.
If it doesn’t. Then replace that servo ASAP.

And as for the remote
my flysky gave me range issues. But mine goes about 100 yards before it cuts off, over 60 yards it had a major lag.
I tried it with 2 receivers that were brand new and both cut off around 100 yards. Everything else worked like a charm.....

I upgraded to a Futaba 4pv range wise it gives me a good 200 yards before it cuts off. I can barely see it.

But I should have stayed with the flysky.
It’s not realistic to play safely with this rc further then 60/80 yards.
Anything over that it becomes a speck or maybe I’m just blind :LOL:

I would say order a new receiver on eBay. They are super cheap.
 

-Dusty-

Well-Known Member
Messages
75
Location
Alberta Canada
Yea I swapped the steering and throttle servo channels and the throttle servo still glitches out. Will see if I can get one off the place I bought it


Not sure about the receiver though. They are $25-$35 since they are still pretty new. Might see if I can return this one to banggood but that would take a few months
 

-Dusty-

Well-Known Member
Messages
75
Location
Alberta Canada
Well Im pretty sure that the servo isn't causing the the crappy range. I unplugged that and still have terrible range. So I guess I gotta see if I can get a replacement from banggood :rolleyes:
 

machine head

Well-Known Member
Messages
89
Those systems have a lot of electrical noise. You need to get a glitch capacitor. You can find them on e-bay for about 7 bucks, get the one with the larges micro fareds. Thats the rating of the capacitor. good luck
 

-Dusty-

Well-Known Member
Messages
75
Location
Alberta Canada
Well I thought I would post a little update.

After a bunch of back and forth with banggood they ended up giving me a partial refund. I got a FG4RS (its super small) receiver off ebay and did a small range test with this. Walked about 100 or so feet with my signal strength still at 10. So I think it was the original receiver that is messed up.

The servo still glitches but not as bad as before. Maybe 2 out of 5 times I turn it on it will glitch out. Got a glitchbuster but it didn't help. Im gonna get a 840wp and return the original to Horizon. Will get a 845 for the steering when needed.

All things considered, I think everything will work out. I didn't really miss out on any run time since we had the coldest February in a long time :p
 
Last edited:

machine head

Well-Known Member
Messages
89
if you buy a glitch capacitor on e bay it will fix the rest of your radio issues. their about 6 bucks, find the one with the largest micro farad specifications good luck machine head
 
Top