servo freezes

marderbeet

Well-Known Member
Messages
249
Location
torrance california
has any body had problems with there servos freezing up. when i run my fg beetle full throtle the steering freezes in the straight possition and i have to swich the on off switch to make it work normal again, i have a dx3 radio and futaba servos and im using the fail safe on the dx3 radio somebody said mayby my jetpro pipe could cause interference but that dosnt make sence
 

Timmahh

Bajastafarian Madnes
PLUS member
Messages
3,376
Location
Michigan
the only way the JP would be causnig issue is if it was rubbing something metal and POSSIBLY cause some interferance, but that pretty unlikly with the specky imo.

have your tried the servo in another application, or another servo where this one is messing up. check you wires too. make sure they are seated into plug, and the plug is firmly seated in the RX.

some metal to metal rubbing can cause glitching, but again, should be pretty none existant with spektrum. is the servo Digi or Analog?
 

marderbeet

Well-Known Member
Messages
249
Location
torrance california
servo

the only way the JP would be causnig issue is if it was rubbing something metal and POSSIBLY cause some interferance, but that pretty unlikly with the specky imo.

have your tried the servo in another application, or another servo where this one is messing up. check you wires too. make sure they are seated into plug, and the plug is firmly seated in the RX.

some metal to metal rubbing can cause glitching, but again, should be pretty none existant with spektrum. is the servo Digi or Analog?
It only happens on full throttle and i have to do is switch the on off switch and it resets fine, i thinks servo is analog 7454
 
Last edited:

Timmahh

Bajastafarian Madnes
PLUS member
Messages
3,376
Location
Michigan
Hitec 7454? thought those were Digis. hmm. not sure. try another servo, it maybe the linkages hanging up.
T
 

marderbeet

Well-Known Member
Messages
249
Location
torrance california
now my buddy has the same problem i had with it glitching but its on a mcd with 2 steering servos, ill check conections and battery. the sterring linkage if too tight could cause a glitch???
 

Bigger the Better

LSF Plus Member
PLUS member
Messages
7,738
Location
Minnesota
I had an old 1800mah battery that was getting old and sure enough glitching with a futaba servo. Its fine now with a new battery. I wonder if its the battery surging?
 

drbelleville

Well-Known Member
Messages
214
Location
houston texas
Hey just curious what radio are you running, because if its an earlier 2.4 Ghz system there is a filter that can be installed to stop any interference / glitches!
 
Top