spektrum probs looking at changing

whizzy

Well-Known Member
Messages
283
Location
paisley
hi over the last couple of weeks running i have noticed that mcd is going into failsafe mode alot and that the failsafe is taking a while to kick in also had my mcd throttle stay on and had to steer it to me and stop it by turning it on its roof and it making me start to lose faith in spektrum for safety and runaways and thats maybe it might be worthwhile looking at the nomadio or futaba 2.4ghz systems has anyone ran any of the other in largescales if so how do they perform
 

WoodiE

Kind of good admin.
Administrator
Messages
1,858
Location
Kentucky
whizzy,

Are you sure your receiver and transmitter batteries or completely charged? Possibly damage from water or anything? I've been running my Spektrum on both my MGT and FG MT for over a year or longer and never have had a single problem with it.



-Michael
 

whizzy

Well-Known Member
Messages
283
Location
paisley
yes both checked and are fine and charged my spektrum transmitter reads 11.4 v when charged
 

MONAROMAN

Well-Known Member
Messages
485
Location
Sydney Australia
I have a dx3 and 4 rx's for 4 cars (2 gas 2 nitro) and had a glitch only ONCE and cannot replicate it, my fg went to about 1/4 throttle (like a throttle blip) not failsafe then was under control again. Are you running 2 steering servos with power thru rx? If so, try running power direct to servos. Have you tried rebinding the rx?
 

whizzy

Well-Known Member
Messages
283
Location
paisley
just to let you guys know i have oredered a nomadio react which will hopefully be here tomorrow
 

marderbeet

Well-Known Member
Messages
249
Location
torrance california
my buddy has been having problems on his new baja 1000 he has the specky dx3 his was glitching with slow throtle response and his steering wouldnt work all the time with it stuck in the straight position for a few seconds, i had him rebind it, it seemed to work for a while and it started up again. is there any thing i can check and ill be installing failsafes on all 3 of our cars soon so ill have it all apart soon. his batt was charged for 4 four hours on my black widow charger on 1amp it blinked saying its ready. could the batt be bad?? hes used the batt 3 times and charged it full b4 every run, its scarry as hell with a 30.5 motor and jetpro on a mcd that looks out of control for a few seconds,!!
 

Bigger the Better

LSF Plus Member
PLUS member
Messages
7,738
Location
Minnesota
my buddy has been having problems on his new baja 1000 he has the specky dx3 his was glitching with slow throtle response and his steering wouldnt work all the time with it stuck in the straight position for a few seconds, i had him rebind it, it seemed to work for a while and it started up again. is there any thing i can check and ill be installing failsafes on all 3 of our cars soon so ill have it all apart soon.
I have had this problem with a hitec servo once and sent it in. They found it to be a loose/cold solder joint. That one was kicking it into failsafe everytime. Did you set his failsafe to 1/2-3/4 brake? You could open the servo and check for damage or try your or another servo and see if it does the same thing.

his batt was charged for 4 four hours on my black widow charger on 1amp it blinked saying its ready. could the batt be bad?? hes used the batt 3 times and charged it full b4 every run, its scarry as hell with a 30.5 motor and jetpro on a mcd that looks out of control for a few seconds,!!
What type of battery is it? If it is a NiCad battery charging before each run without discharging may cause problems but normaly not glitching problems. If it is a NiMh battery 1amp is too low and may false peak on some chargers, take it up to a minimum of 2 and the best they say is 3amps.
 

kingwalker

New Member
Messages
2
Location
adelaide
spektrum

hi over the last couple of weeks running i have noticed that mcd is going into failsafe mode alot and that the failsafe is taking a while to kick in also had my mcd throttle stay on and had to steer it to me and stop it by turning it on its roof and it making me start to lose faith in spektrum for safety and runaways and thats maybe it might be worthwhile looking at the nomadio or futaba 2.4ghz systems has anyone ran any of the other in largescales if so how do they perform
i love my new dx3 it bounced off the wall and hit the wife thank god it missed my dog piece off shit is the dx3:2guns::)
 

dirby

Well-Known Member
Messages
230
Location
Dothan Al
get rid of the spectrum
get a futaba 3pm fasst 2.4 gig.
that will take care of all your problems.
Dirby
 

dirby

Well-Known Member
Messages
230
Location
Dothan Al
for running a Baja r other large scale .
the 3pm will do all you need.
the 4 pk is for hard core racers and has all the whistles and bells you can imagine.
but for general bashing rge 3pm will do the job.
 

tnh

New Member
Messages
1
interesting

Just found this post, I just installed 2 new hitec 5745's in my new MCD, installed my spectrum DX3R radio did the "binding" thing, set the frame rate for digital servos, and I got a terrible "lead-lag between the steering wheel and servo response, plus the servos were not in sink (both servos are connected with a Y-harness for dual setup). fully charge battery, I'm stumped, so I change to my Futaba 3PK-PCM radio and it works great. I just did'nt want to have to worry about channel frequencies, thats why I got the spectrum. any Ideas?
tnh
 

Ducky

Well-Known Member
Messages
644
Location
Kent, UK
Can you run the system in analogue mode to see if it makes any difference? Might be worth starting a new thread of your own so it's easier to keep track of problems.
 

Bigger the Better

LSF Plus Member
PLUS member
Messages
7,738
Location
Minnesota
Just found this post, I just installed 2 new hitec 5745's in my new MCD, installed my spectrum DX3R radio did the "binding" thing, set the frame rate for digital servos, and I got a terrible "lead-lag between the steering wheel and servo response, plus the servos were not in sink (both servos are connected with a Y-harness for dual setup). fully charge battery, I'm stumped, so I change to my Futaba 3PK-PCM radio and it works great. I just did'nt want to have to worry about channel frequencies, thats why I got the spectrum. any Ideas?
tnh
Did you set it to the highest rate - 5.5ms: Gives the fastest response rate,
however, is only compatible with high performance digital servos.

Don't use a Y connector and set it up mixed. See page 25 of your manual.
Manual for DX3

I would say that two 5745's is over kill and you would be ok with one and keep the 2nd for a spare.

If in doubt Spektrum service is great: Please call 877-504-0233 with any questions or concerns regarding this product or warranty.
 
Last edited:
Top