spents obr 57 twin dragon hammer,

spents

Uncle Fester👻
PLUS member
Messages
1,057
Location
oop north
Anytime uncle Paul :LOL:.... bravo on the clean wrap on that body and the hole punch tool...forgot to mention to you that the cables are green too so it will fit with the hammers color
thanks nephew (y):LOL:,
its not a wrap though ryan, the greens paint (y), just the black protectors for the screws are vinyl carbon stuff (y),
or have i misunderstood yer post :LOL:,
spot on with the green cables then ryan (y)(y),
have you looked at the tracking on the cables ryan ? there defo doing the rounds :ROFLMAO::ROFLMAO:,
 

spents

Uncle Fester👻
PLUS member
Messages
1,057
Location
oop north
sooooo, ryan @Rep732 sent me some pull start cables , thanks again ryan (y)(y),
so dremelled a ramp/slot in the spool for the cable to sit in and also so the cable sits flatish in the spool ,



then fed the cable into the spool, space is super tight cos of the extra secondary spring thats in there for the ezi start,
should stay there though, its in quite tight (y):LOL:,



then wound the cable round the spool, a few turns on the main spring etc and then fed cable through the handle and crimped one of the ends on after stripping some green off the end (y),
i have to admit i had one slip up, though, i didnt think the main spring was seated right in the slot, so gave it a jiggle and ya can guess what happened,
yep, main spring wound round my hand and tangled to feck :ROFLMAO::ROFLMAO:,
so re wound the spring and started again, alls good now and starter jjust needs refitting then testing after i connect the wiring back up and refit the pipes (y)(y),

 

spents

Uncle Fester👻
PLUS member
Messages
1,057
Location
oop north
soooo good and bad news on the hammer front :ROFLMAO:,
good news is that ryans cables are spot on (y)(y),
feels much better to pull the engine over with a cable as opposed to a cord (y),
so everything refitted and sorted,





engine still high on the compression, but pre warmed the engine a tad with heat gun, just up to around 50c and its easier to pull over,
the twins always been like this though, once its fired up then it will start after 1 or 2 pulls all day,
but had a no start today, has great spark, has fuel etc but nope, wouldnt have it,
not even a pop on choke,
some may remember form a few posts above that it just didnt sound right last time i had it running,
pulled the filters and puddle of fuel in bottom of each air box,
i did notice that the carbs when pumping the bulbs were circulating air bubbles in the return line way after the shoulda been,
all fuel lines are right and tight and clunks are fully submerged etc,
so, pulled the carbs and gonna go through em again, i did fit some rebuild kits a few pages ago, so maybe i got sommat not quite right,
or maybe the carbs are just too worn, they are the original carbs from when i bought the engine,
carbs off again :ROFLMAO:,
quick check finger over fuel inlet and circulates proper and holds pressure on inlet with finger over the hole,



i'll strip em tomorrow and see if owt seems amiss (y),
yeh long ass post :LOL:,

 

spents

Uncle Fester👻
PLUS member
Messages
1,057
Location
oop north
Ffs🤦‍♂️ keep us posted
On a side note, M8 of mine is sending me his twin and an Obr head kit. Im to do a rebuild . Ill start a thread when it all comes in👏🏻
lmao doug, yeh i'll keep ya'll posted (y):D,
its sommat simples though, just a fuelling issue (y), will strip the carbs and redo em, check everything and go from there,
if it still don't play ball then its getting a fresh pair of carbs,

yeh defo start a thread doug (y), be interesting to see a full rebuild on yer mates twin,
is it going from rcmk heads to obr then ?
 

spents

Uncle Fester👻
PLUS member
Messages
1,057
Location
oop north
soo, carbs stripped again :D,



went right through em and gave every orifice a thorough clean out etc,
also changed out the needle valves and metering levers for new ones this time as well,
all back together and waiting to go back on the twin again :LOL:(y),

 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock    No Thanks