Engine is not running and i cant find the issue!

Thread starter #21
Messages
5
Likes
6
How did you run it when it was running? In the grass? If so, do you have outerwares on the pull start? If not, could be grass stuffed in between the gap of the coil pickup and flywheel. Ask me how I know.:oops: That's when outerwares were bought.
Hmmm spent around 2 hours earlier trying everything discussed and no luck. One thing I need to try which is a good idea is what crucialRC said- I do indeed run it in grass. Hope it’s this otherwise- well I don’t know what will happen then! When I pull it it fires and then dies immediately, then it does not fire any longer until I remove the fuel lines and get all the fuel out the carb, then it will fire and die again until I put the lines BACK on. Seems to be stuck in a cycle of flooding itself until it’s starved and then it will just flood itself again!
 

Z.hb71

Well-Known Member
Messages
2,307
Likes
1,310
Location
From rainy, boring, humid, Manvel, Texas
Hmmm spent around 2 hours earlier trying everything discussed and no luck. One thing I need to try which is a good idea is what crucialRC said- I do indeed run it in grass. Hope it’s this otherwise- well I don’t know what will happen then! When I pull it it fires and then dies immediately, then it does not fire any longer until I remove the fuel lines and get all the fuel out the carb, then it will fire and die again until I put the lines BACK on. Seems to be stuck in a cycle of flooding itself until it’s starved and then it will just flood itself again!
Lean out the low speed needle,
 
Messages
5
Likes
0
This is the first time I’ve done one of these forum thingys so bare with me!
Basically the engine in my DBXL was running around a month ago but not brilliantly. At the start of the week i went to start it but it wasn’t having it. For the entire of this week i have been spending my evenings trying to work out why its not starting. So far i have:
Fitted a brand new spark plug
Cleaned the carb twice
Drained all fuel out of it and replaced with new
Put the stock exhaust back on

When i put the choke lever down it coughs a bit and runs for around a second like usual, however when i take it off choke it runs for around 2 seconds if I’m lucky and then dies. If i try and pull it without the choke after this then it doesn’t even fire so i have to start the process all over again with much frustration. HELP, what do i do as I’m out of ideas!
Takes three things to run. compression. right amount of fuel mixture "gas and air" and fire at the right time. Check Fire at plug make sure its firing ok. Blue spark. check plug to see if its wet. if so, its flooded or not firing. If its dry no fuel or no fire to the plug or out of time. flywheel key possibly sheered. You said it would start for a second so probably not key. Check needle valve in carburetor for proper adjustment or sticking. disassemble carb spray carb cleaner through all passages and make sure they are clear. check needle valve height and it should run . If the diaphragms are stiff it wont pump fuel either. Hope this helps.
 
Top