Register and gain access to Discussions, Reviews, Tech Tips, How to Articles, and much more - on the largest Large Scale RC community for RC enthusiasts that covers all aspects of the Large Scale RC!

Register Today It's free! This box will disappear once registered!

Servo issue

Discussion in 'Losi Desert Buggy XL' started by Nickdric, Aug 10, 2017.

  1. Nickdric

    Nickdric New Member

    Joined:
    Aug 10, 2017
    Messages:
    1
    Likes Received:
    0
    When I turn on the car the throttle servo pulsates and when I move the servo with the controller it pulsates even more. I'm using the stock battery. The battery is charged when it happens because I can still steer without that servo pulsating. If you could please help it would be appreciated. Thanks
     
  2. D-Mann Rc

    D-Mann Rc Member

    Joined:
    Dec 31, 2016
    Messages:
    7
    Likes Received:
    4
    I would take my throttle servo horn off and let the servo set it self to center when you turn it on and then reattach the servo horn again if it is still giving you a problem then you need to go into your controller and make some adjustment to your end points it seams to me that your throttle servo is over working and it needs to be tone down a bit ,oh also check you throttle linkage to.
     
  3. Paul G

    Paul G Active Member

    Joined:
    Feb 22, 2017
    Messages:
    41
    Likes Received:
    7
    Another thing is the potentiometer in the servo. When they go bad you can't get back to zero. It will constantly look for its "neutral" position. Maybe time for a new one. Water will cause this to happen.


    Sent from my iPhone using Tapatalk