Just got an FG Monster Beetle!

Thread starter #221

Gamefan

Well-Known Member
Messages
451
Likes
157
Location
Denver, USA
Hi 1Coopgt,

I thing caught was the wrong word. I need to activate the break when I hit revere on the remote but it goes in the wrong direction.

Just need to know how to setup brakes properly for an FG.

Thank you!
 
Thread starter #223

Gamefan

Well-Known Member
Messages
451
Likes
157
Location
Denver, USA
Hi Dougstar,

If I am throttling the brake is also being applied. Not sure how to make it only throttle and then brake when I pull forward on the trigger.
 

dougstar

Well-Known Member
Messages
1,172
Likes
971
Location
KZN South Africa
1538317323659.png
thats a pic of the steering sevo its not possible to throttle and brake @ the same time. the horn is on a central pivot the one is always opposite
the other. send apic of what you have on your setup(y)
 
Thread starter #225

Gamefan

Well-Known Member
Messages
451
Likes
157
Location
Denver, USA
Got it sorted. Had the throttle connector on facing upwards instead of downward. All set now.

Thank you Dougstar! Going out today to break in the engine.
 
Thread starter #228

Gamefan

Well-Known Member
Messages
451
Likes
157
Location
Denver, USA
Took it out today and did a tank idle break-in. Idles smoothly and quietly with the FG tuned pipe.

Also was able to drive around a little on second tank. Power band needs adjusting but all is good right now.

Thank you everyone for helping me get this going! I truely appreciate it!
 
Thread starter #230

Gamefan

Well-Known Member
Messages
451
Likes
157
Location
Denver, USA
Looking to break in some more this coming weekend. I did notice that after the engine was all warmed up, the speed was there. One questions though.

When I am first taking it out, I have to pull the throttle trigger all the way back. Once it moves, I can let go a little and then pull the trigger again for more power. Is that normal?

Thank you!
 
Thread starter #231

Gamefan

Well-Known Member
Messages
451
Likes
157
Location
Denver, USA
Gave this to my Brother in Law and he has now given it back to me.

Going to do a thorough cleaning as it is muddy as all get out!

Still starts right up so that is good!
 

crucialRC

Well-Known Member
Messages
192
Likes
181
Location
Maryland, USA
Looking to break in some more this coming weekend. I did notice that after the engine was all warmed up, the speed was there. One questions though.

When I am first taking it out, I have to pull the throttle trigger all the way back. Once it moves, I can let go a little and then pull the trigger again for more power. Is that normal?

Thank you!
Possibly rich condition, try leaning the low needle a little.
 
Top